Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
E
eclipse-debian-helper
Manage
Activity
Members
Labels
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Model registry
Operate
Environments
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Terms and privacy
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
pkg
eclipse-debian-helper
Commits
e2730489
Commit
e2730489
authored
1 year ago
by
Ritesh Raj Sarraf
Browse files
Options
Downloads
Plain Diff
Merge updates from debian/bookworm
parents
efa5852e
a68b25a1
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
debian/changelog
+9
-2
9 additions, 2 deletions
debian/changelog
debian/control
+1
-1
1 addition, 1 deletion
debian/control
src/perl/eclipse_bundles.pm
+31
-9
31 additions, 9 deletions
src/perl/eclipse_bundles.pm
with
41 additions
and
12 deletions
debian/changelog
+
9
−
2
View file @
e2730489
eclipse-debian-helper (1.9) unstable; urgency=medium
* Support multiple bundles directories
* Standards-Version updated to 4.6.1
-- Emmanuel Bourg <ebourg@apache.org> Mon, 12 Dec 2022 11:55:33 +0100
eclipse-debian-helper (1.8+apertis1) apertis; urgency=medium
* Set component to sdk.
...
...
@@ -48,14 +55,14 @@ eclipse-debian-helper (1.5) unstable; urgency=medium
eclipse-debian-helper (1.4) unstable; urgency=medium
* Team upload.
* Support other bundle dir
r
ectories than 'bundles' and the base directory
* Support other bundle directories than 'bundles' and the base directory
-- Jochen Sprickerhof <jspricke@debian.org> Fri, 19 Oct 2018 13:13:21 +0200
eclipse-debian-helper (1.3) unstable; urgency=medium
* Add a symlink in /usr/lib/eclipse/plugins/ when installing a plugin
* New parameter to set the shortname of a bundle
* New parameter to set the short
name of a bundle
-- Emmanuel Bourg <ebourg@apache.org> Fri, 28 Sep 2018 00:21:02 +0200
...
...
This diff is collapsed.
Click to expand it.
debian/control
+
1
−
1
View file @
e2730489
...
...
@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Uploaders: Emmanuel Bourg <ebourg@apache.org>
Build-Depends: debhelper-compat (= 13),
Standards-Version: 4.
5.0
Standards-Version: 4.
6.1
Vcs-Git: https://salsa.debian.org/java-team/eclipse-debian-helper.git
Vcs-Browser: https://salsa.debian.org/java-team/eclipse-debian-helper
Homepage: https://salsa.debian.org/java-team/eclipse-debian-helper
...
...
This diff is collapsed.
Click to expand it.
src/perl/eclipse_bundles.pm
+
31
−
9
View file @
e2730489
...
...
@@ -29,17 +29,35 @@ sub new {
chomp
$bundles
;
@
{
$this
->
{
bundles
}}
=
split
(
/ /
,
$bundles
);
if
(
-
d
"
$this
->{bundles}[0]
")
{
$this
->
{
bundledir
}
=
"
.
";
}
elsif
(
-
d
"
bundles/
$this
->{bundles}[0]
")
{
$this
->
{
bundledir
}
=
"
bundles
";
}
else
{
die
"
Couldn't locate the base directory of the bundles
";
# Locate the bundle directories
@
{
$this
->
{
bundledirs
}}
=
getBundleDirectories
(
$this
);
if
(
scalar
@
{
$this
->
{
bundledirs
}}
==
0
)
{
die
"
WARNING: Couldn't locate the base directory of the bundles
";
}
return
$this
;
}
#
# Locates the directories containing at least one of the bundles defined
# in debian/bundles.
#
sub
getBundleDirectories
{
my
$this
=
$_
[
0
];
my
%bundledirs
=
();
my
@directories
=
`
find . -maxdepth 2 -type d -printf '%P
\n
' | sort
`;
for
my
$directory
(
@directories
)
{
chomp
(
$directory
);
for
my
$bundle
(
@
{
$this
->
{
bundles
}})
{
my
$bundledir
=
$this
->
get_sourcepath
(
$directory
.
"
/
"
.
$bundle
);
if
(
-
d
$bundledir
)
{
$bundledirs
{
$directory
}
=
"";
}
}
}
return
sort
keys
%bundledirs
;
}
sub
build
{
my
$this
=
shift
;
my
$d_ant_prop
=
$this
->
get_sourcepath
('
debian/ant.properties
');
...
...
@@ -48,8 +66,10 @@ sub build {
push
(
@args
,
'
-propertyfile
',
$d_ant_prop
);
}
my
@bundledirs
=
@
{
$this
->
{
bundledirs
}};
push
(
@args
,
"
-Dbasedir
",
"
.
");
push
(
@args
,
"
-Dbundledir
",
$
this
->
{
bundledir
}
);
push
(
@args
,
"
-Dbundledir
",
$bundledir
s
[
0
]
);
push
(
@args
,
"
-f
",
"
debian/build.xml
");
for
my
$bundle
(
@
{
$this
->
{
bundles
}})
{
push
(
@args
,
basename
(
$bundle
));
...
...
@@ -100,8 +120,10 @@ sub clean {
my
$this
=
shift
;
$this
->
doit_in_builddir
("
rm
",
"
-Rf
",
"
debian/bundles.properties
");
for
my
$bundle
(
@
{
$this
->
{
bundles
}})
{
$this
->
doit_in_builddir
("
rm
",
"
-Rf
",
"
$this
->{bundledir}/
$bundle
/target
");
for
my
$bundledir
(
@
{
$this
->
{
bundledirs
}})
{
for
my
$bundle
(
@
{
$this
->
{
bundles
}})
{
$this
->
doit_in_builddir
("
rm
",
"
-Rf
",
"
$bundledir
/
$bundle
/target
");
}
}
$this
->
doit_in_builddir
("
mh_clean
");
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment