Skip to content
Snippets Groups Projects
  • Ariel D'Alessandro's avatar
    68b58d12
    import-debian-package: Allow creating/pushing to remote repository · 68b58d12
    Ariel D'Alessandro authored
    
    To import a new package from Debian the current process required several
    manual steps. This commit adds the --push-remote option to allow
    creating and pushing the imported package to apertis remote gitlab
    instance.
    
    The following steps are now automatized:
    * package folder is created and import process is performed in there.
    * remote repo is created if it doesn't exist.
    * remote branches and tags are pushed.
    * gitlab settings are applied to remote repo.
    * CI pipeline is triggered on all downstream branches.
    
    Signed-off-by: default avatarAriel D'Alessandro <ariel.dalessandro@collabora.com>
    68b58d12
    History
    import-debian-package: Allow creating/pushing to remote repository
    Ariel D'Alessandro authored
    
    To import a new package from Debian the current process required several
    manual steps. This commit adds the --push-remote option to allow
    creating and pushing the imported package to apertis remote gitlab
    instance.
    
    The following steps are now automatized:
    * package folder is created and import process is performed in there.
    * remote repo is created if it doesn't exist.
    * remote branches and tags are pushed.
    * gitlab settings are applied to remote repo.
    * CI pipeline is triggered on all downstream branches.
    
    Signed-off-by: default avatarAriel D'Alessandro <ariel.dalessandro@collabora.com>
control 812 B
Source: apertis-dev-tools
Section: devel
Priority: extra
Maintainer: Apertis package maintainers <packagers@lists.apertis.org>
Build-Depends:
 debhelper (>= 9),
 flatpak,
 git-buildpackage,
 ostree,
 python3-argcomplete,
 python3-debian,
 python3-sh,
 python3-xdg,
 python3-yaml,
 python3-paramiko,
 python3-gi,
Standards-Version: 3.9.8

Package: apertis-dev-tools
Architecture: all
Depends:
 ${shlibs:Depends},
 ${misc:Depends},
 ${pythons3:Depends},
 flatpak,
 git-buildpackage,
 gitlab-rulez,
 python3-argcomplete,
 python3-debian,
 python3-sh,
 python3-xdg,
 python3-yaml,
 python3-paramiko,
 python3-gi,
 python3-gitlab,
 systemd-container
Suggests:
 ribchester (>= 0.1612.7)
Recommends: gcc-arm-linux-gnueabihf
Description: Apertis development tools to help building, deploying and
 debugging applications