Skip to content
Snippets Groups Projects
Forked from pkg / systemd
75 commits behind the upstream repository.
systemd-journal-flush-Add-a-requirement-on-var.mount.patch 1.74 KiB
From: Detlev Casanova <detlev.casanova@collabora.com>
Date: Wed, 26 Jan 2022 15:30:42 -0500
Subject: systemd-journal-flush: Add a requirement on var.mount.

On some systems (like ostree), /var is already mounted (bind) when systemd
starts and is not in /etc/fstab, so there is no var.mount file (fragment)
generated by systemd-fstab-generator

var.mount unit still exists: it instantiated via /proc/self/mountinfo

RequiresMountsFor= does not add Requires= dependencies for .mount units if
there is no corresponding fragment file (it still adds them After=, though -
see unit_add_mount_dependencies() in unit.c)
=> systemd-journal-flush.service will have After=var.mount but no
   Requires=var.mount.
=> On shutdown, nothing causes systemd-journal-flush.service to be stopped as
   it does not require var.mount.

See https://github.com/systemd/systemd/issues/867#issuecomment-890768048
for details

This patch adds the Require= for var.mount. It fixes the unmounting of
/var at shutdown and doesn't influence systems that let systemd mount
/var.

Signed-off-by: Detlev Casanova <detlev.casanova@collabora.com>
---
 units/systemd-journal-flush.service | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/units/systemd-journal-flush.service b/units/systemd-journal-flush.service
index 1a71592..e258866 100644
--- a/units/systemd-journal-flush.service
+++ b/units/systemd-journal-flush.service
@@ -11,7 +11,7 @@
 Description=Flush Journal to Persistent Storage
 Documentation=man:systemd-journald.service(8) man:journald.conf(5)
 DefaultDependencies=no
-Requires=systemd-journald.service
+Requires=systemd-journald.service var.mount
 After=systemd-journald.service systemd-remount-fs.service
 Before=systemd-tmpfiles-setup.service
 RequiresMountsFor=/var/log/journal