1. 05 Apr, 2022 3 commits
  2. 24 Aug, 2021 2 commits
  3. 11 Mar, 2021 1 commit
  4. 22 Feb, 2021 1 commit
  5. 30 Mar, 2020 1 commit
  6. 24 Feb, 2020 1 commit
    • Mark Brown's avatar
      Import Debian changes 1:1.2.11.dfsg-2 · cee6ca34
      Mark Brown authored
      zlib (1:1.2.11.dfsg-2) unstable; urgency=low
      
        * Acknowledge previous NMUs (closes: #949388).
        * Remove zlib1g-dbg in favour of dbgsym (closes: #497831, #926161).
        * Rename stage1 to nobiarch, patch no longer applies due to
          uncoordinated NMUs (closes: #892762).
        * Debhelper has renamed -s to -a.
        * Policy 4.5.0 (no changes).
      
      zlib (1:1.2.11.dfsg-1.2) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Fix ftbfs on mips64el caused by the previous NMU by
          remove it from 32-ARCHS to keep NMU minial.
      
      zlib (1:1.2.11.dfsg-1.1) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Enable lib64 for mipsn32 mipsn32el mipsr6 mipsr6el mipsn32r6 mipsn32r6el x32
          help to add binutils-host64 for 32bit architectures (Closes: 949388)
        * Remove outdated binutils version requirement for mips/mipsel.
      cee6ca34
  7. 01 Jun, 2019 1 commit
  8. 25 Sep, 2017 1 commit
    • Mark Brown's avatar
      Import Debian changes 1:1.2.11.dfsg-1 · a192ecf8
      Mark Brown authored
      zlib (1:1.2.11.dfsg-1) unstable; urgency=low
      
        * New upstream release (closes: #883180).
        * Use debian/patches/series to cope with yet more tooling issues with
          patches format (closes: #896078).
        * Use DEP-5 format (closes: #862260).
      
      zlib (1:1.2.8.dfsg-5) unstable; urgency=low
      
        * Add loud warnings to the descriptions of all the multilib packages
          to try to discurage anyone from using them in error, the *only* user
          is the D compiler which does this because apparently D users will
          want to do cross builds but will be unable to install multilib
          packages.  No new packages should add usage, it is difficult to see
          any sensible use case (closes: #787956, #845793, #709623, #853087).
      
      zlib (1:1.2.8.dfsg-4.1) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Revert "Install zconf.h in multiarch path"; this broke lib{32,64}z1-dev
          and is not necessary with upstream version 1.2.8 (Closes: #787956)
        * Revert "Fix cross 32 builds."; this broke lib64z1-dev (Closes: #845793)
        * Add stage1 profile that excludes multilib packages (Closes: #709623)
      
      zlib (1:1.2.8.dfsg-4) unstable; urgency=high
      
        * Apply upstream fix for CVE-2016-9840.
      
      zlib (1:1.2.8.dfsg-3) unstable; urgency=high
      
        * Apply upstream fix for CVE-2016-9841 (closes: #847270).
        * Apply upstream fix for CVE-2016-9842 (closes: #847274).
        * Apply upstream fix for CVE-2016-9843 (closes: #847275).
        * Standards version 3.9.8 (no changes).
      
      zlib (1:1.2.8.dfsg-2) unstable; urgency=low
      
        * Drop zlib-bin package as minizip has now been packaged separately,
          delay due to lack of notice regarding upload (closes: #753070).
      
      zlib (1:1.2.8.dfsg-1) unstable; urgency=low
      
        * New upstream release.
        * Policy 3.9.4.
        * Tweak version for gzseek64 and gztell64 (closes: #687076).
        * Install zconf.h in multiarch path (closes: #698648).
      
      zlib (1:1.2.7.dfsg-13) unstable; urgency=low
      
        * Yet more s390x cleanup.  Thanks to the s390x porters for thei
          prompt an efficient buildd monitoring (closes: #678511).
      
      zlib (1:1.2.7.dfsg-12) unstable; urgency=low
      
        * Clean up breakage from binnmu since with multiarch binnmus of zlib
          and other multiarch enabled library packages aren't actually
          installable.  Hopefully the multiarch people will get round to
          cleaning up the infrastructure at some point (closes: #678172).
      
      zlib (1:1.2.7.dfsg-11) unstable; urgency=low
      
        * Third time lucky.  I love double negative logic on strings.  It's a
          shame the patch for s390x didn't take care of s390...
      
      zlib (1:1.2.7.dfsg-10) unstable; urgency=low
      
        * Nope, here we go again... 
      
      zlib (1:1.2.7.dfsg-9) unstable; urgency=low
      
        * Let's try a different bodge for s390...
      
      zlib (1:1.2.7.dfsg-8) unstable; urgency=low
      
        * Yet another special case for s390.
      
      zlib (1:1.2.7.dfsg-7) unstable; urgency=low
      
        * Fix cross 32 builds.
      
      zlib (1:1.2.7.dfsg-6) unstable; urgency=low
      
        * Pass LDFLAGS to minizip too, but don't bother with TEST_LDFLAGS
          for the main build since it accomplishes nothing (closes: #672310).
        * Disallow simutaneous 64 and 32 bit cross package builds.
      
      zlib (1:1.2.7.dfsg-5) unstable; urgency=low
      
        * s390x doesn't actually have 32 bit, only 31 bit, and making the
          compiler options consistent is too hard. 
      
      zlib (1:1.2.7.dfsg-4) unstable; urgency=low
      
        * Move primary shared library to /lib for wpa_supplicant (closes: #591013).
      
      zlib (1:1.2.7.dfsg-3) unstable; urgency=low
      
        * Clean up ironic breakage in patch for hardening (closes: #672310).
        * Support biarch on s390x (closes: #637898).
      
      zlib (1:1.2.7.dfsg-2) unstable; urgency=low
      
        * Enable hardening flags, yet another release goal which we've
          suddenly decided to start work on close to the end of the release
          cycle.  Patch from Moritz Mühlenhoff (closes: #672310).
      
      zlib (1:1.2.7.dfsg-1) unstable; urgency=low
      
        * New upstream release.
      
      zlib (1:1.2.6.dfsg-2) unstable; urgency=low
      
        * Break texlive-binaries before 2009-12 due to gzeof() behaviour
          change (closes: #659681).
      
      zlib (1:1.2.6.dfsg-1) unstable; urgency=low
      
        * New upstream release.
        * OMG!!!!! MULTIARCH!!!#!!! (closes: #569697).
        * Break older libxml (closes: #589134).
        * Drop bzr repo, it's adding nothing and painful to use.
      
      zlib (1:1.2.5.dfsg-1) experimental; urgency=low
      
         * New upstream release.
      
      zlib (1:1.2.3.5.dfsg-1) experimental; urgency=low
      
         * New upstream release.
         * Remove most of the contrib directory so we don't have to waste time
           writing a copyright file for code we don't build (closes: #561432).
      
      zlib (1:1.2.3.4.dfsg-3) unstable; urgency=low
      
        * Only check for EOF on transparent streams if we have done a zero
          byte read to avoid reporting EOF early to applications.  This was
          breaking R.
      
      zlib (1:1.2.3.4.dfsg-2) unstable; urgency=low
      
        * Revert explict EOF indication to avoid triggering an infinite loop
          in man-db while rebuilding the caches (closes: #562518).
      
      zlib (1:1.2.3.4.dfsg-1) unstable; urgency=low
      
        * New upstream release.
        * This release contains refactored handling of 64 bit types which should
          stop warnings being generated in some configurations (closes: #439980).
        * This release also fixes handling of EOF in gzio (closes: #301283).
        * Fix symbol version for inflateUndermine.
        * Move -dbg to debug section.
        * Add upstream home page. 
        * Policy 3.8.3.
      
      zlib (1:1.2.3.3.dfsg-16) unstable; urgency=low
      
        * Concert to 3.0 (quilt) format.
      
      zlib (1:1.2.3.3.dfsg-15) unstable; urgency=low
      
        * Using Conflicts instead of Replaces for the amd64 lib32 transition
          since that's the latest idea for making it work (closes: #539278).
      
      zlib (1:1.2.3.3.dfsg-14) unstable; urgency=low
      
        * amd64 has finally abandoned /emul/ia32-linux so install the 32 bit
          binaries in lib32 as for other architectures (closes: #533015).
      
      zlib (1:1.2.3.3.dfsg-13) unstable; urgency=low
      
        * Add LPIA to the list of unaligned architectures to reduce the Ubuntu
          diff a little (closes: #517403).
      
      zlib (1:1.2.3.3.dfsg-12) unstable; urgency=low
      
        * Apply patch from Arthur Loiret <arthur.loiret@u-psud.fr> implementing
          triarch support for MIPS (closes: #474097).
      
      zlib (1:1.2.3.3.dfsg-11) unstable; urgency=low
      
        * Correct library names for cross libraries.
        * Turns out all our 64 bit architectures do off64_t.
      
      zlib (1:1.2.3.3.dfsg-10) unstable; urgency=low
      
        * dpkg-shlibdeps doesn't deal well with unbuilt packages (closes: 461474).
        * Support packages using 64 bit cross symbols even when off_t is 64
          bits.
      
      zlib (1:1.2.3.3.dfsg-9) unstable; urgency=low
      
        * Remove Debian revisions from symbol files.
      
      zlib (1:1.2.3.3.dfsg-8) unstable; urgency=low
      
        * Add symbols files.  Version information is provided by the upstream
          map file.  Architecture lists may need some adjustment.
        * Fix udeb contents.
        * Policy 3.7.3 (no changes).
      
      zlib (1:1.2.3.3.dfsg-7) unstable; urgency=low
      
        * Hard code uname to GNU so configure script can cope with non-Linux 
          ports (closes: #448651).
      
      zlib (1:1.2.3.3.dfsg-6) unstable; urgency=low
      
        * Configure the compiler and linker to use for the vanilla build too so that
          cross compilation works (closes: #444727).
      
      zlib (1:1.2.3.3.dfsg-5) unstable; urgency=low
      
        * x86_64 uses a non-standard directory for the 32 bit runtime so we need
          to do something completely different there (closes: #432262).
      
      zlib (1:1.2.3.3.dfsg-4) unstable; urgency=low
      
        * dh_makeshlibs needs to be handheld when building multiple library
          packages (closes: #431873).
      
      zlib (1:1.2.3.3.dfsg-3) unstable; urgency=low
      
        * Support building with UNALIGNED_OK and enable it on i386 and amd64.
          This seems to provide a small speedup in my tests (closes: #386357).
        * Build 32 bit version on KFreeBSD-amd64 (closes: #406018).
        * Provide versioned dependency shlibs (closes: #431124).
      
      zlib (1:1.2.3.3.dfsg-2) unstable; urgency=low
      
        * Add XS-VCS-Bzr.
      
      zlib (1:1.2.3.3.dfsg-1) unstable; urgency=low
      
        * New upstream release.
        * Repackage without DBS, use quilt to manage patches instead.
        * Drop checks for epoch support in dpkg.
        * Upstream now supports _FILE_OFFSET_BITS (closes: #234237).
        * Remove Provides: zlib1g from udeb (closes: #419603).
        * Add -dbg packages.
      
      zlib (1:1.2.3-15) unstable; urgency=low
      
        * Apparently gcc-multilib is actually a replacement for the arch-specific
          GCCs (closes: #424657).
      
      zlib (1:1.2.3-14) unstable; urgency=low
      
        * The vibrations tell me that cross builds need to build depend on
          gcc-multilib.
        * Remove Provides: zlib1g from udeb (closes: #419603).
      
      zlib (1:1.2.3-13) unstable; urgency=low
      
        * Add dependency from lib32z1-dev to lib32c-dev (closes: #376854).
      
      zlib (1:1.2.3-12) unstable; urgency=low
      
        * Apply patch from Volker Grabsch <vog@notjusthosting.com> fixing cross
          compilation.
      
      zlib (1:1.2.3-11) unstable; urgency=low
      
        * Add udeb line to shlibs (closes: #355293).
      
      zlib (1:1.2.3-10) unstable; urgency=low
      
        * Add a note to the gzerror() documentation specifying the rules for access
          to the returned string (closes: #353407).
        * Add a note to the gzclose() documentation pointing out that since the
          function will always free the stream gzerror() can't be used to translate
          the error message into plain text (closes: #354310).
        * Change build dep to libc6-dev-i386 on amd64 (closes: #355170).
      
      zlib (1:1.2.3-9) unstable; urgency=low
      
        * Remove build dep on amd64-libs (closes: #344009).
      
      zlib (1:1.2.3-8) unstable; urgency=low
      
        * Replace old ia32-libs (closes: #339105).
      
      zlib (1:1.2.3-7) unstable; urgency=low
      
        * Check for EOF properly in gzio (closes: #130557).
      
      zlib (1:1.2.3-6) unstable; urgency=low
      
        * Most of the changes in this version are based heavily on work done for
          Ubuntu by Matthias Klose <doko@cs.tu-berlin.de>.  Thanks!
        * Build biarch packages on PowerPC (closes: #325560).
        * Build biarch packages on i386, replacing amd64-libs prior to 1.4 which
          included its own copy and adding a theoretically spurious build dep
          on amd64-libs to work around binutils troubles (closes: #334013).
        * Drop build dep on GCC 3.4 on amd64 - we already stopped using it.
        * Update all the lib64 development dependencies to use lib64c-dev rather
          than the specific libc-${ARCH}-dev package.
        * Don't test lib64 builds - there's a good chance they'll fail due to the
          system not being able to execute 64 bit code.  Similarly, don't worry if
          dh_shlibdeps fails and hard code an unversioned dependency on the
          appropriate libc.
      
      zlib (1:1.2.3-5) unstable; urgency=low
      
        * Since GCC no longer ICEs at -O3 on m68k revert to using -O3 there like
          we do elsewhere.
      
      zlib (1:1.2.3-4) unstable; urgency=low
      
        * Add ppc64 biarch support using patch included in the report by Andreas
          Jochens <aj@andaco.de> (closes: #323591).
      
      zlib (1:1.2.3-3) unstable; urgency=low
      
        * Fix minizip build (closes: #321355).
      
      zlib (1:1.2.3-2) unstable; urgency=low
      
        * Fix noopt (closes: #320999).
        * Apply CFLAGS to minizip too.
        * Policy 3.6.2 (no changes).
      
      zlib (1:1.2.3-1) unstable; urgency=high
      
        * New upstream release.
        * This release includes a fix for CAN-2005-1849.
      
      zlib (1:1.2.2-9) unstable; urgency=low
      
        * Work around an ICE on m68k by building at -O2 there.
        * Implement noopt support while we're at it.
      
      zlib (1:1.2.2-8) unstable; urgency=low
      
        * Remove GCC 3.4 hack for amd64 since the default compiler is now supposed
          to be able to do biarch.
      
      zlib (1:1.2.2-7) unstable; urgency=high
      
        * Add patch fixing CAN-2005-2096 in inflate.
      
      zlib (1:1.2.2-6) unstable; urgency=low
      
        * Fix some build failures on amd64 (closes: #316779).  The package still
          fails to build but this appears to be due to toolchain issues.
      
      zlib (1:1.2.2-5) unstable; urgency=low
      
        * Build a 32 bit copy on amd64 (closes: #311618).
        * Hack build with GCC 3.4 on amd64 since the default 3.3 is broken for
          biarch builds.  This should be removed once the default compiler does
          this properly.
        * Remove libc5 support and therefore revert to using plain gcc when not
          cross-compiling.
        * Upgrade to Debhelper interface 4.
      
      zlib (1:1.2.2-4) unstable; urgency=low
      
        * Run dh_installdeb before dh_shlibdeps (closes: #282882).
        * Specify the shlibs for the library directly to dpkg-shlibs.
      
      zlib (1:1.2.2-3) unstable; urgency=low
      
        * Generate shared libraries sensibly for zlib-bin (closes: #278977).
      
      zlib (1:1.2.2-2) unstable; urgency=low
      
        * Remove shlibs from udeb.
      
      zlib (1:1.2.2-1) unstable; urgency=low
      
        * New upstream release.
      
      zlib (1:1.2.1.2-1) unstable; urgency=low
      
        * New upstream release.
        * Upstream now includes patch improving error reporting when gzio is used on
          empty files (closes: #258087).
        * Upstream have fixed a valgrind warning.  Other valgrind warnings remain
          but have been analysed and found safe - uninitialised memory is read from
          a buffer allocated by zlib during deflate but bounds checking is
          subsequently performed and the output unaffected (closes: #270070).
      
      zlib (1:1.2.1.1-7) unstable; urgency=high
      
        * Once more, with feeling.
      
      zlib (1:1.2.1.1-6) testing; urgency=high
      
        * Fix the error handling in the new inflate implementation to avoid
          incorrectly continuing to process in the error state.  Thanks to Johan
          Thelmén <johan.thelmen@cygate.se> for his help in finding and fixing this
          bug.  This is CAN-2004-0797 (closes: #252253).
      
      zlib (1:1.2.1.1-5) unstable; urgency=low
      
        * Build a 64 bit libz on s390 and sparc.  Original patch provided by Bastian
          Blank <waldi@debian.org> but since modified (closes: #257940).
        * Mark the udeb as such for Debhelper but note that the udeb support appears
          not to cope with epochs so leave the code to build it.
        * Apply patch from David Weinehall <tao@debian.org> avoiding some XSIisms in
          the package scripts (closes: #256363).
        * Policy 3.6.1 (no changes).
      
      zlib (1:1.2.1.1-4) unstable; urgency=low
      
        * Incorporate current upstream patch to minizip.  This supercedes most of
          the current Debian patches (8,14,15 and 17) and has some additional
          bugfixes.
      
      zlib (1:1.2.1.1-3) unstable; urgency=low
      
        * Fix -fPIC provision for HPPA (closes: #249289).
        * Provide -D_REENTRANT while we're at it.
      
      zlib (1:1.2.1.1-2) unstable; urgency=low
      
        * Build with debug symbols.
        * Revert partially done 64 bit support.
      
      zlib (1:1.2.1.1-1) unstable; urgency=low
      
        * New upstream release with bugfix for inflate (closes: #221590).
      
      zlib (1:1.2.1-5) unstable; urgency=low
      
        * Apparently udebs shouldn't call ldconfig (closes: #237345).
      
      zlib (1:1.2.1-4) unstable; urgency=low
      
        * Make checks when minizip is skipping arguments less likely to generate
          false positives (closes: #231036).
      
      zlib (1:1.2.1-3) unstable; urgency=low
      
        * Use dpkg-architecture to get the target architecture and use the compiler
          it tells us to.
        * Don't run the testsuite when we're cross-compiling.
      
      zlib (1:1.2.1-2) unstable; urgency=low
      
        * Version build dependency on the DBS package (closes: #221599).
      
      zlib (1:1.2.1-1) unstable; urgency=low
      
        * New upstream release.
        * The override fie tells me zlib1g is now required.
        * Use dbs package to build rather than carting around our own copy.
        * Many patches have been incorporated upstream.
        * Upstream no longer has a readme.txt for zlib-bin.
        * Check the return value of scanf() in miniunzip.
      
      zlib (1:1.1.4-17) unstable; urgency=low
      
        * Support GNU/KFreeBSD (closes: #220844).
      
      zlib (1:1.1.4-16) unstable; urgency=low
      
        * Check the return value of scanf in minizip (closes: #215658).
        * Issue a diagnostic if minizip has no ZIP file to work on (closes: #215657).
      
      zlib (1:1.1.4-15) unstable; urgency=low
      
        * Replace "udeb" with "for Debian installer" in the short description for
          the udeb (closes: #211019).
        * Fix conflicts between real binary package and udeb.
      
      zlib (1:1.1.4-14) unstable; urgency=low
      
        * Remove the libc5 libraries from the control file.  Apparently the archive
          software isn't too keen on having packages built for the null set of
          architectures.
      
      zlib (1:1.1.4-13) unstable; urgency=low
      
        * Nothing's actually appeared that uses the fact that zlib is in /lib so
          move it back to /usr/lib.
        * Drop libc5 support since it's breaking builds.  The infrastructure is
          still there so if we do decided to continue building libc5 stuff after all
          it can be added back.
      
      zlib (1:1.1.4-12) unstable; urgency=low
      
        * Change section of zlib1g-dev to libdevel.
        * GCC has now complains about improper usage of functions even without
          prototypes so fix vsnprintf() test to call vsnprintf() with the
          correct arguments (closes: #194828).
      
      zlib (1:1.1.4-11) unstable; urgency=low
      
        * The "Premature implementation is the root of all evil" release.
        * Change udeb name to zlib1g-udeb (closes: #183296).
        * Make the udeb provide zlib1g.
      
      zlib (1:1.1.4-10) unstable; urgency=low
      
        * Fix buffer overflow in gzprintf() by adding configure test for
          vsnprintf() and failing the build out if it's not used.
        * Use snprintf() for printing file descriptor name in gzdopen().
        * Remove Emacs variables from changelog.
      
      zlib (1:1.1.4-9) unstable; urgency=low
      
        * Build a zlib-udeb package.  The changes are a modified version of some
          provided by Sebastian Ley <sebastian.ley@mmweg.rwth-aachen.de>.
        * Updated Standards-Version to 3.5.8 (no changes).
        * Don't check for the preprocessor constant i386 in zconf.h, use the
          better namespaced __i386__ instead.
      
      zlib (1:1.1.4-8) unstable; urgency=low
      
        * Leave libz.so in /usr/lib (closes: #169924).
      
      zlib (1:1.1.4-7) unstable; urgency=low
      
        * Install libz.so in /lib rather than /usr/lib (closes: #168797).
      
      zlib (1:1.1.4-6) unstable; urgency=low
      
        * Depend on libc-dev rather than libc6-dev (closes: #164649).
      
      zlib (1:1.1.4-5) unstable; urgency=low
      
        * Include patch from Joel Baker <lucifer@lightbearer.com> forcing -Dunix
          when building minizip for NetBSD (closes: #164060).
        * Don't set /usr/doc link in zlib1-altdev.
      
      zlib (1:1.1.4-4) unstable; urgency=low
      
        * Complete sentance in minzip.1 (closes: #160929).
      
      zlib (1:1.1.4-3) unstable; urgency=low
      
        * Update upstream URL in copyright file (closes: #154940).
      
      zlib (1:1.1.4-2) unstable; urgency=low
      
        * Build glibc static library without PIC (closes: #149939).
      
      zlib (1:1.1.4-1) unstable; urgency=low
      
        * New upstream release.
      
      zlib (1:1.1.3-19.1) unstable; urgency=high
      
        * Non-maintainer upload
        * Apply patch for double-free bug
      
      zlib (1:1.1.3-19) unstable; urgency=low
      
        * Include patch to minizip from Steve Kemp <skx@tardis.ed.ac.uk>
          fixing various stability issues with minizip.
      
      zlib (1:1.1.3-18) unstable; urgency=low
      
        * Fix -d option support so that archives can be extracted without 
          using -d (closes: #119898).
        * s/pkzip/PKZIP/ in control file.
      
      zlib (1:1.1.3-17) unstable; urgency=low
      
        * Add patch from Dirk Eddelbuettel <edd@debian.org> supporting an
          additional "-d extractdir" option and correcting the miniunzip
          manual page (closes: #118658).
      
      zlib (1:1.1.3-16) unstable; urgency=low
      
        * Add to LD_LIBRARY_PATH rather than setting it since fakeroot now
          relies on setting it (closes: #108553).
      
      zlib (1:1.1.3-15) unstable; urgency=low
      
        * Call tar with --force-local in debian/rules to force it to interpret
          filenames as filenames (closes: #96078).
        * Supply manual pages for minizip and miniunzip.
        * Update description of libc5 packages to mention that they are
          libc5 variants.
      
      zlib (1:1.1.3-14) unstable; urgency=low
      
        * Update debian/rules for m68k again (closes: #91863).
        * Upgrade priority of zlib1g to standard.
        * Update to policy 3.5.2 (no changes).
      
      zlib (1:1.1.3-13) unstable; urgency=low
      
        * Don't build libc5 packages on m68k any more (closes: #90639).
      
      zlib (1:1.1.3-12) unstable; urgency=low
      
        * Install zlib.3 in zlib1g-dev (closes: #78122).
        * Update to policy 3.2.1 (no changes).
      
      zlib (1:1.1.3-11) unstable; urgency=low
      
        * Build-depends on debhelper (closes: #72400).
      
      zlib (1:1.1.3-10) unstable; urgency=low
      
        * Fix bashism in build.vars (closes: #71756).
      
      zlib (1:1.1.3-9) unstable; urgency=low
      
        * Fix source dependancies (closes: #68469).
      
      zlib (1:1.1.3-8) unstable; urgency=low
      
        * New maintainer.
        * Initialise DH_OPTIONS in debian/rules (closes: #67113).
        * Add source dependancies.
        * Update copyright information.
      
      zlib (1:1.1.3-7) unstable; urgency=low
      
        * Fixed zlib1g shlibs.  Closes: #67164.
      
      zlib (1:1.1.3-6) unstable; urgency=low
      
        * Joel is taking a leave of absence(indefinate).  He has given the package
          to me.
        * Ported to dbs, an enhanced source management system.
        * Ported to debhelper.
        * Fix broken libz.so link in -altdev.  Closes: #54573.
        * Incorrect shlibs file on hurd.  Fixed in -5.  Closes: #56125.
      
      zlib (1:1.1.3-5) unstable; urgency=low
      
        * Remove sparc from libc5-compat architectures.
        * control: zlib1g: Provide libz1.
          zlib1g-dev: Provide libz-dev.
        * shlibs-libc6: Use libz1.
        * /usr/doc symlinks.
        * Correct zlib-bin description in debian/control.
        * Only call ldconfig when configuring (closes:Bug#42518).
        * Add hurd configure patch (closes:Bug#46899).
        * Ensure contrib.tar.gz is really tarred *and* gzipped (closes:Bug#30367,#32001).
        * zlib1g-dev has had the man page since 1.1.3-1 (closes:Bug#23802).
        * Fix URL in minizip (closes:Bug#43888).
        * Install example.c and minigzip.c in zlib1g-dev examples (closes:Bug#32002).
      
      zlib (1:1.1.3-4) unstable; urgency=low
      
        * Policy 3.0.1.
        * dpkg-architecture variables.
        * zlib-bin: `miniunz' -> `miniunzip'.
        * Source package is zlib again.
      
      zlib1 (1:1.1.3-3) unstable; urgency=low
      
        * Made zlib-bin package containing `minizip' and `miniunz'.
      
      zlib1 (1:1.1.3-2) unstable; urgency=low
      
        * Fix incorrect dependency in shlibs files (Bug:#28083).
      
      zlib1 (1:1.1.3-1) unstable; urgency=low
      
        * New maintainer (hijacking the package due to non-response of
                          active maintainer to repeated queries).
        * New upstream release.
        * (shlibs-libc6): Paranoia: depend on >= 1:1.1.3.
          (shlibs-libc5): likewise.
        * (debian/control): changed source package to 'zlib1'.
        * Fix /usr/doc/libz*
        * Add contrib directory as .tar.gz in zlib1g-dev.
        * Add man page.
        * Add README, FAQ and algorithm.txt.
        * lintian clean.
        * Added sparc to libc5-compat architectures.
      
      zlib (1:1.1.2-0.1) unstable; urgency=low
      
        * New upstream bugfix release.
        * libc5 compat packages are now built on only i386 and m68k.
      
      zlib (1:1.1.1-0.1) unstable; urgency=low
      
        * Non maintainer release.
        * New upstream release.
        * Made symlink in zlib1-altdev relative (fixes lintian warning).
        * Removed executable bit on shared libs (fixes several lintian warnings).
      
      zlib (1:1.0.4-7.1) unstable; urgency=low
      
        * Updated for libc6
        * Compiled with -D_REENTRANT.
        * Non mantainer release.
      
      zlib (1:1.0.4-7) stable unstable; urgency=low
      
        * Include --assert-working-epoch so people can't try to install with
          bogus dpkg. (Bug#6848)
        * Correct zlib1-dev description. (Bug#6061).
      
      zlib (1:1.0.4-6) stable unstable; urgency=high
      
        * Recompile with correct libc requirement.
        * Correct zlib1-dev deps to include zlib1.
      
      zlib (1:1.0.4-5) stable; urgency=low
      
        * Add epoch, to make dselect happier
      
      zlib (1.0.4-4) stable; urgency=high
      
        * Remember to copy shlibs file to DEBIAN directory (thanks to Christoph
          Lameter
      
      zlib (1.0.4-3) unstable; urgency=low
      
        * Added shlibs file
        * Insured that shared library was stripped (Bug#5316)
      
      zlib (1.0.4-2) unstable; urgency=low
      
        * Accomodate the fact that dpkg-source doesn't properly preserve
          permissions on scripts when extracting package.
      
      zlib (1.0.4-1) unstable; urgency=low
      
        * New upstream version.
        * Moved to new source packaging format.
      a192ecf8
  9. 31 May, 2019 1 commit