1. 04 Jan, 2022 4 commits
    • Ritesh Raj Sarraf's avatar
    • Ritesh Raj Sarraf's avatar
      Merge remote-tracking branch 'origin/apertis/v2023dev1' into... · 0da3b976
      Ritesh Raj Sarraf authored
      Merge remote-tracking branch 'origin/apertis/v2023dev1' into proposed-updates/debian/bullseye-security/544f2c1b
      
      * origin/apertis/v2023dev1: (26 commits)
        Refresh the automatically detected licensing information
        Release webkit2gtk version 2.34.1-1~deb11u1+apertis1
        Refresh the automatically detected licensing information
        Release webkit2gtk version 2.32.4-1~deb11u1+apertis1
        Refresh the automatically detected licensing information
        d/a/copyright: Set license for third_party/m4sugar m4 scripts
        Release webkit2gtk version 2.32.3-1+apertis1
        Drop build dependency on libmanette
        Refresh the automatically detected licensing information
        Release webkit2gtk version 2.30.5-1apertis2
        copyright: Ignore M4 macros not affecting build artifacts
        copyright: Document Bison-exception-2.2 on the skeletons themselves
        d/control: Remove libenchant-2-dev dependency
        Release webkit2gtk version 2.30.5-1apertis1
        Release webkit2gtk version 2.30.5-1~deb10u1co1
        Releasing apertis version 2.30.4-1~deb10u1co1.
        Releasing apertis version 2.30.3-1~deb10u1co1.
        Refresh the automatically detected licensing information
        copyright: Add licensing metadata
        Release webkit2gtk version 2.28.4-1~deb10u1co1
        ...
      0da3b976
    • Alberto Garcia's avatar
      Import Debian changes 2.34.3-1~deb11u1 · 27321a63
      Alberto Garcia authored
      27321a63
    • Apertis CI's avatar
      Import Upstream version 2.34.3 · 8f80898b
      Apertis CI authored
      8f80898b
  2. 29 Oct, 2021 5 commits
  3. 28 Sep, 2021 5 commits
  4. 23 Aug, 2021 1 commit
  5. 22 Aug, 2021 1 commit
  6. 21 Aug, 2021 2 commits
  7. 19 Aug, 2021 1 commit
    • Ritesh Raj Sarraf's avatar
      Merge remote-tracking branch 'origin/apertis/v2022dev3' into... · f59beebb
      Ritesh Raj Sarraf authored
      Merge remote-tracking branch 'origin/apertis/v2022dev3' into proposed-updates/debian/bullseye/8174aaa8
      
      * origin/apertis/v2022dev3:
        Refresh the automatically detected licensing information
        Release webkit2gtk version 2.30.5-1apertis2
        copyright: Ignore M4 macros not affecting build artifacts
        copyright: Document Bison-exception-2.2 on the skeletons themselves
        d/control: Remove libenchant-2-dev dependency
        Release webkit2gtk version 2.30.5-1apertis1
        Release webkit2gtk version 2.30.5-1~deb10u1co1
        Releasing apertis version 2.30.4-1~deb10u1co1.
        Releasing apertis version 2.30.3-1~deb10u1co1.
        Refresh the automatically detected licensing information
        copyright: Add licensing metadata
        Release webkit2gtk version 2.28.4-1~deb10u1co1
        Release webkit2gtk version 2.28.2-2~deb10u1co1
        debian/apertis/component: Set to target
        Release webkit2gtk version 2.26.2-1~deb10+1co1
        Release webkit2gtk version 2.26.1-3~deb10u1co1
        Release webkit2gtk version 2.24.4-1~deb10u1co1
        Import Apertis version 2.24.4-1~deb10u1
      f59beebb
  8. 11 Aug, 2021 2 commits
  9. 20 Apr, 2021 4 commits
  10. 19 Apr, 2021 1 commit
  11. 22 Mar, 2021 2 commits
  12. 19 Feb, 2021 3 commits
  13. 17 Feb, 2021 1 commit
    • Alberto Garcia's avatar
      Import Debian changes 2.30.5-1~deb10u1 · 33e206fe
      Alberto Garcia authored
      webkit2gtk (2.30.5-1~deb10u1) buster-security; urgency=medium
      
        * Rebuild for buster-security.
        * debian/patches/force-single-process.patch:
          + Force the single-process mode in Evolution and Geary
        * debian/control:
          + Remove Breaks for Evolution < 3.34.1.
          + Remove build dependency on libwpebackend-fdo-1.0-dev.
          + Switch build dependency from libenchant-2-dev to libenchant-dev.
          + Switch build dependencies on libgl-dev and libgles-dev with
            libgl1-mesa-dev and libgles2-mesa-dev.
      
      webkit2gtk (2.30.5-1) unstable; urgency=high
      
        * New upstream release (Closes: #978042).
        * Remove some obsolete build dependencies (Closes: #979170):
          + gawk is not needed since WebKitGTK switched from autotools to CMake.
          + libgeoclue-2-dev and geoclue-2.0 are not required since WebKitGTK
            2.25.1 (upstream bug 195994).
          + libupower-glib-dev is not required since WebKitGTK 2.19.92 (upstream
            bug 181825).
          + libfile-copy-recursive-perl is not required since WebKitGTK 2.19.3
            (upstream bug 180479).
          + mesa-common-dev used to provide GL/gl.h but this header is now in
            libgl-dev.
          + libgles2-mesa-dev used to provide GLES3/gl3.h but this header is now
            in libgles-dev.
          + libgl1-mesa-dev and libgles2-mesa-dev are now dummy packages.
          + libpango1.0-dev is not checked for any specific version at build
            time so there's no need to list it.
        * Update the minimum required versions of some packages:
          + cmake from 3.3 to 3.10
          + libglib2.0-dev from 2.36.0 to 2.44.0
          + libgtk-3-dev from 3.10.0 to 3.22.0
          + libcairo2-dev from 1.10.2 to 1.14.0
          + libsoup2.4-dev from 2.42.0 to 2.54.0.
        * debian/patches/fix-mips-page-size.patch:
          + Increase the page size from 4KB to 16KB on MIPS, this fixes a crash
            with Loongson CPUs that don't support 4KB pages (Closes: #977779).
        * debian/copyright:
          + Update copyright years.
        * debian/watch:
          + Set version to 4 (fixes older-debian-watch-file-standard).
        * debian/control:
          + Update Standards-Version to 4.5.1 (no changes).
      
      webkit2gtk (2.30.4-1) unstable; urgency=high
      
        * New upstream release.
        * The WebKitGTK security advisory WSA-2020-0008 lists the following
          security fixes in the latest versions of WebKitGTK:
          + CVE-2020-9952 (fixed in 2.28.3).
          + CVE-2020-9948, CVE-2020-9951 (fixed in 2.30.0).
          + CVE-2020-9983, CVE-2020-13584 (fixed in 2.30.3).
      33e206fe
  14. 07 Jan, 2021 1 commit
    • Alberto Garcia's avatar
      Import Debian changes 2.30.5-1 · 693744b4
      Alberto Garcia authored
      webkit2gtk (2.30.5-1) unstable; urgency=high
      
        * New upstream release (Closes: #978042).
        * Remove some obsolete build dependencies (Closes: #979170):
          + gawk is not needed since WebKitGTK switched from autotools to CMake.
          + libgeoclue-2-dev and geoclue-2.0 are not required since WebKitGTK
            2.25.1 (upstream bug 195994).
          + libupower-glib-dev is not required since WebKitGTK 2.19.92 (upstream
            bug 181825).
          + libfile-copy-recursive-perl is not required since WebKitGTK 2.19.3
            (upstream bug 180479).
          + mesa-common-dev used to provide GL/gl.h but this header is now in
            libgl-dev.
          + libgles2-mesa-dev used to provide GLES3/gl3.h but this header is now
            in libgles-dev.
          + libgl1-mesa-dev and libgles2-mesa-dev are now dummy packages.
          + libpango1.0-dev is not checked for any specific version at build
            time so there's no need to list it.
        * Update the minimum required versions of some packages:
          + cmake from 3.3 to 3.10
          + libglib2.0-dev from 2.36.0 to 2.44.0
          + libgtk-3-dev from 3.10.0 to 3.22.0
          + libcairo2-dev from 1.10.2 to 1.14.0
          + libsoup2.4-dev from 2.42.0 to 2.54.0.
        * debian/patches/fix-mips-page-size.patch:
          + Increase the page size from 4KB to 16KB on MIPS, this fixes a crash
            with Loongson CPUs that don't support 4KB pages (Closes: #977779).
        * debian/copyright:
          + Update copyright years.
        * debian/watch:
          + Set version to 4 (fixes older-debian-watch-file-standard).
        * debian/control:
          + Update Standards-Version to 4.5.1 (no changes).
      
      webkit2gtk (2.30.4-1) unstable; urgency=high
      
        * New upstream release.
        * The WebKitGTK security advisory WSA-2020-0008 lists the following
          security fixes in the latest versions of WebKitGTK:
          + CVE-2020-9952 (fixed in 2.28.3).
          + CVE-2020-9948, CVE-2020-9951 (fixed in 2.30.0).
          + CVE-2020-9983, CVE-2020-13584 (fixed in 2.30.3).
      693744b4
  15. 29 Dec, 2020 3 commits
  16. 21 Dec, 2020 1 commit
    • Alberto Garcia's avatar
      Import Debian changes 2.30.4-1~deb10u1 · aad7d9d3
      Alberto Garcia authored
      webkit2gtk (2.30.4-1~deb10u1) buster-security; urgency=medium
      
        * Rebuild for buster-security.
        * debian/patches/force-single-process.patch:
          + Force the single-process mode in Evolution and Geary
        * debian/control:
          + Remove Breaks for Evolution < 3.34.1.
          + Remove build dependency on libwpebackend-fdo-1.0-dev.
          + Switch build dependency from libenchant-2-dev to libenchant-dev.
      
      webkit2gtk (2.30.4-1) unstable; urgency=high
      
        * New upstream release.
        * The WebKitGTK security advisory WSA-2020-0008 lists the following
          security fixes in the latest versions of WebKitGTK:
          + CVE-2020-9952 (fixed in 2.28.3).
          + CVE-2020-9948, CVE-2020-9951 (fixed in 2.30.0).
          + CVE-2020-9983, CVE-2020-13584 (fixed in 2.30.3).
      
      webkit2gtk (2.30.3-1) unstable; urgency=high
      
        * New upstream release
      aad7d9d3
  17. 25 Nov, 2020 3 commits