1. 30 Mar, 2020 1 commit
  2. 21 Aug, 2019 1 commit
  3. 22 Mar, 2018 1 commit
    • Jeremy Bicha's avatar
      Import Debian changes 3.28-1 · cf0f0834
      Jeremy Bicha authored
      gnome-themes-extra (3.28-1) unstable; urgency=medium
      
        * New upstream release
          - Fixes broken index.theme for High Contrast icons (Closes: #890845)
        * debian/copyright: Add more copyright holders (Closes: #892980)
      
      gnome-themes-extra (3.27.92-1) unstable; urgency=medium
      
        [ Jeremy Bicha ]
        * New upstream release
      
        [ Adam Conrad ]
        * Change gnome-themes-standard-data versioned Breaks to an unversioned
          Conflicts to let update-manager remove the old package on upgrading.
      
      gnome-themes-extra (3.27.90.1-1) unstable; urgency=medium
      
        * New upstream release (LP: #1644662)
          - Renamed from gnome-themes-standard to gnome-themes-extra
        * Update Vcs fields for migration to https://salsa.debian.org/
        * Update gnome-accessibility-themes description to mention icons.
        * Bump debhelper compat to 11
      
      gnome-themes-standard (3.22.3-4) unstable; urgency=medium
      
        * Update Vcs fields for conversion to git
        * Add debian/gbp.conf
        * Bump Standards-Version to 4.1.2
      
      gnome-themes-standard (3.22.3-3) unstable; urgency=medium
      
        * Don't depend on GTK+ 2 to allow these themes to be installed without
          requiring GTK+ 2 to be installed.
      
      gnome-themes-standard (3.22.3-2) unstable; urgency=medium
      
        [ Michael Biebl ]
        * Drop obsolete Breaks/Replaces
        * Make gnome-themes-standard depend on gtk2-engines-pixbuf instead of only
          recommending it. Nowadays the package only ships the Adwaita GTK+ 2 theme
          which requires the pixbuf theme engine and is broken without it.
          (Closes: #880603)
        * Use dh_missing and abort on uninstalled files
        * Bump Standards-Version to 4.1.1
      
        [ Jeremy Bicha ]
        * Update package descriptions to mention that these packages only
          provide GTK+ 2 versions of themes.
      
      gnome-themes-standard (3.22.3-1) unstable; urgency=medium
      
        [ Jeremy Bicha ]
        * New upstream bugfix release
        * Drop dark_theme.diff, applied in new release
      
      gnome-themes-standard (3.22.2-2) unstable; urgency=medium
      
        * Backport upstream fixes to build and install the Adwaita dark theme
          properly (closes: #853044).
      
      gnome-themes-standard (3.22.2-1) unstable; urgency=medium
      
        [ Laurent Bigonville ]
        * New upstream release.
        * debian/gnome-themes-standard-data.install: Install the Adwaita-dark theme
      
        [ Michael Biebl ]
        * Demote Depends on adwaita-icon-theme to Recommends.
          We want to have the matching Adwaita cursor theme installed by default,
          but it's not a hard dependency.
        * Convert from cdbs to dh.
        * Bump debhelper compat level to 10.
      
      gnome-themes-standard (3.20.2-3) unstable; urgency=medium
      
        * debian/rules: Pass --as-needed to dh_autoreconf and pass additional flags
          to the linker to ensure that the library has no dependencies on undefined
          symbols, and speed up loading.
      
      gnome-themes-standard (3.20.2-2) unstable; urgency=medium
      
        * Replace libgtk-3-bin Build-Depends with gtk-update-icon-cache, which now
          provides the gtk-update-icon-cache utility. The binary no longer uses a
          Debian specific -3.0 suffix so we can also drop
          debian/patches/01_gtk-update-icon-cache_name.patch.
        * Bump debhelper compatibility level to 9.
      
      gnome-themes-standard (3.20.2-1) unstable; urgency=medium
      
        * New upstream release.
        * Bump Standards-Version to 3.9.8.
      
      gnome-themes-standard (3.20-1) unstable; urgency=medium
      
        * New upstream release.
        * Bump Standards-Version to 3.9.7, no changes needed.
      
      gnome-themes-standard (3.18.0-2) unstable; urgency=medium
      
        * Move cursor.theme to adwaita-icon-theme package. It belongs there
          really, and has nothing to do with Gtk+ 2 themes that are shipped
          in gnome-themes-standard packages.
          - Depend on adwaita-icon-theme ≥ 3.18.0-2~.
        * Update descriptions of gnome-themes-standard packages to reflect
          the reality (they now only contain the Gtk+ 2 version of Adwaita).
      
      gnome-themes-standard (3.18.0-1) unstable; urgency=medium
      
        * New upstream release.
      
      gnome-themes-standard (3.16.2-2) unstable; urgency=medium
      
        * Upload to unstable.
      
      gnome-themes-standard (3.16.2-1) experimental; urgency=medium
      
        * New upstream release.
          - Drops the Metacity themes (new versions of both Mutter and Metacity
            can use the Gtk+ theme for window decorations, in addition the
            Adwaita and HighContrast themes will be shipped in metacity-common
            package).
          - Drops the HighContrast Gtk+ 3 theme (moved into gtk+3.0 itself).
        * Make gnome-themes-standard-data break pre-3.16 versions of Mutter and
          Metacity.
        * Bump Standards-Version to 3.9.6, no changes needed.
      
      gnome-themes-standard (3.14.2.2-1) unstable; urgency=medium
      
        * New upstream stable release.
          + Many improvements in the GTK2 theming.
      
      gnome-themes-standard (3.14.0-1) unstable; urgency=medium
      
        * New upstream release.
      
      gnome-themes-standard (3.13.90-2) unstable; urgency=medium
      
        * Upload to unstable.
      
      gnome-themes-standard (3.13.90-1) experimental; urgency=medium
      
        [ Andreas Henriksson ]
        * New upstream development release.
          - Note: default background moved to gnome-backgrounds.
          - Note: adwaita-icon-theme split out to separate source.
        * gnome-themes-standard-data:
          - stop installing adwaita icon theme, now built from its own source.
          - depend on adwaita-icon-theme
          - stop installing gnome-background-properties xml
        * Stop installing gtk-3.0 theme-engines (themes are now pure css)
        * Bump Standards-Version 3.9.5
      
        [ Sjoerd Simons ]
        * debian/control.in: Let gnome-themes-standard-data break gtk (<< 3.13). New
          themes can't be rendered by old gtk causing applications to be unusable.
      
      gnome-themes-standard (3.12.0-1) unstable; urgency=medium
      
        * New upstream release.
      
      gnome-themes-standard (3.10.0-2) unstable; urgency=medium
      
        * Upload to unstable.
      
      gnome-themes-standard (3.10.0-1) experimental; urgency=low
      
        [ Jackson Doak ]
        * New upstream release
        * debian/control: Bump gtk3 b-dep
        * Refresh patch to apply cleanly
      
      gnome-themes-standard (3.8.4-1) unstable; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (3.8.3-1) unstable; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (3.8.1-2) unstable; urgency=low
      
        [ Josselin Mouette ]
        * Add missing /usr/share/icons/default. Closes: #709549.
      
      gnome-themes-standard (3.8.1-1) unstable; urgency=low
      
        [ Josselin Mouette ]
        * Install a cursor.theme to configure the default X cursor.
        * Set up the x-cursor-theme alternative.
      
        [ Michael Biebl ]
        * Upload to unstable.
        * New upstream release.
        * Bump Standards-Version to 3.9.4. No further changes.
        * The LowContrast and HighContrastInverse themes were dropped upstream.
          Clean up the icon cache files and directories on upgrades.
      
      gnome-themes-standard (3.8.0-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (3.7.92-1) experimental; urgency=low
      
        [ Jeremy Bicha ]
        * debian/control.in: Bump minimum GTK
      
        [ Emilio Pozuelo Monfort ]
        * New upstream release.
      
      gnome-themes-standard (3.7.91-1) experimental; urgency=low
      
        [ Jeremy Bicha ]
        * gnome-themes-standard.gconf-defaults:
          - Dropped, gconf isn't being used for themes any more
      
        [ Emilio Pozuelo Monfort ]
        * New upstream release.
      
      gnome-themes-standard (3.7.90-1) experimental; urgency=low
      
        * New upstream release.
          + debian/patches/01_gtk-update-icon-cache_name.patch:
            - Refreshed.
          + debian/control.in:
            - Updated build dependencies.
      
      gnome-themes-standard (3.6.2-1) experimental; urgency=low
      
        [ Sjoerd Simons ]
        * Recommend gtk2-engines-pixbuf instead of gtk2-engines. Closes: #691691
      
        [ Michael Biebl ]
        * New upstream release.
      
        [ Theppitak Karoonboonyanan ]
        * Split out gnome-accessibility-themes to fullfill the old dependencies.
          (Closes: #661471)
        * Capitalize "GNOME" in package description. [lintian]
        * Split out gnome-themes-standard-data for arch-indep files. [lintian]
        * Add multi-arch support.
          - Bump B-Deps debhelper (>= 8.1.3), cdbs (>= 0.4.93~).
          - d/rules: Add DEB_CONFIGURE_EXTRA_FLAGS.
          - Declare M-A: same for gnome-themes-standard; M-A: foreign for
            gnome-themes-standard-data & gnome-accessibility-themes.
      
        [ Josselin Mouette ]
        * The above closes: #694055.
        * New upstream release.
        * Only recommend gnome-accessibility-themes. The metapackages will be
          in charge of the Depends.
        * Build-depend on libgtk2.0-dev.
        * Install GTK2 engine.
        * Stop removing .la files, we don’t list them in *.install anyway.
      
      gnome-themes-standard (3.6.0.2-2) experimental; urgency=low
      
        * Break libgtk2.0-0 (<< 2.24.13) as old version can't parse the new themes
      
      gnome-themes-standard (3.6.0.2-1) experimental; urgency=low
      
        * New upstream release
      
      gnome-themes-standard (3.4.2-2.1) unstable; urgency=low
      
        * Non-maintainer upload.
        * Split out gnome-accessibility-themes to fullfill the old dependencies.
          (Closes: #661471)
        * Capitalize "GNOME" in package description. [lintian]
        * Split out gnome-themes-standard-data for arch-indep files. [lintian]
      
      gnome-themes-standard (3.4.2-2) unstable; urgency=low
      
        * Point Vcs-* to unstable branch.
        * Rebuild with xz compression. Closes: #687283
      
      gnome-themes-standard (3.4.2-1) unstable; urgency=low
      
        * New upstream release.
        * Upstream now correctly skips the generation of icon-theme.cache when
          DESTDIR is used, so remove the workaround from debian/rules.
      
      gnome-themes-standard (3.4.1-2) unstable; urgency=low
      
        * Upload to unstable.
      
      gnome-themes-standard (3.4.1-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (3.4.0-2) experimental; urgency=low
      
        * Remove icon-theme.cache file. We don't want to ship this file in the
          package but rather generate it at installation time. Closes: #666188
      
      gnome-themes-standard (3.4.0-1) experimental; urgency=low
      
        [ Martin Pitt ]
        * New upstream release.
        * debian/control.in: Update Vcs-* for experimental branch.
        * debian/control.in: Add libcairo2-dev, libgdk-pixbuf2.0-dev, and
          libglib2.0-dev build dependencies as per configure.ac.
        * Add 01_gtk-update-icon-cache_name.patch: Debian packaging uses
          gtk-update-icon-cache-3.0, update path in configure.ac.
        * debian/control.in, debian/rules: Use dh-autoreconf, for the patch above.
        * debian/control.in: Bump Standards-Version to 3.9.3 (no changes necessary).
      
        [ Michael Biebl ]
        * Add Build-Depends on libgtk-3-bin for gtk-update-icon-cache-3.0.
      
      gnome-themes-standard (3.3.91-1) experimental; urgency=low
      
        * New upstream development release.
        * debian/control.in: Bump Build-Depends on libgtk-3-dev to (>= 3.3.14).
      
      gnome-themes-standard (3.2.1-2) unstable; urgency=low
      
        [ Josselin Mouette ]
        * Break libmutter0 < 3.2, since it doesn’t support the new theme.
      
        [ Michael Biebl ]
        * Upload to unstable.
      
      gnome-themes-standard (3.2.1-1) experimental; urgency=low
      
        [ Sjoerd Simons ]
        * New upstream release
        * debian/control.in: Update libgtk-3-dev depends and add librsvg2-dev
          build-depends
      
        [ Michael Biebl ]
        * debian/watch:
          - Switch to .xz tarballs.
          - Track stable releases.
          - Don't run uupdate.
      
      gnome-themes-standard (3.0.2-1) unstable; urgency=low
      
        * New upstream release.
        * debian/control.in
          - Add Vcs-* fields.
          - Bump Standards-Version to 3.9.2. No further changes.
      
      gnome-themes-standard (3.0.0-2) unstable; urgency=low
      
        * Recommend gtk2-engines for Clearlooks.
        * gnome-themes-standard.gconf-defaults: set Adwaita as the default
          theme when this package is installed. This will fix the behavior of
          GTK3 apps in unstable.
      
      gnome-themes-standard (3.0.0-1) experimental; urgency=low
      
        * New upstream release.
        * debian/control.in: bump build-dependency on libgtk-3-dev to 3.0.8.
      
      gnome-themes-standard (2.91.93-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.92.1-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.92-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.91.1-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.91-2) experimental; urgency=low
      
        * Add missing replaces on gnome-accessibility-themes.
      
      gnome-themes-standard (2.91.91-1) experimental; urgency=low
      
        * New upstream release.
        * debian/control.in: bump libgtk-3-dev build-dependency.
      
      gnome-themes-standard (2.91.90.1-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.90-1) experimental; urgency=low
      
        * New upstream release.
      
      gnome-themes-standard (2.91.8-1) experimental; urgency=low
      
        * New upstream release.
          + debian/control.in:
            - Update the gtk+ 3 build dependency for the new package name.
            - Drop depends on gtk-theme-engine-clearlooks, no longer needed.
      
      gnome-themes-standard (2.91.7-1) experimental; urgency=low
      
        * New upstream release.
          + debian/rules:
            - Update the theme engine location.
      
      gnome-themes-standard (2.91.6-1) experimental; urgency=low
      
        * New upstream release.
          + debian/control.in:
            - gnome-themes-standard is now arch:any.
            - Update build dependencies.
          + debian/rules:
            - Switch to CDBS.
            - Don't install .la files, thanks.
      
      gnome-themes-standard (2.91.5-1) experimental; urgency=low
      
        * New upstream release.
        * Make the package arch:all.
      
      gnome-themes-standard (2.91.4-1) experimental; urgency=low
      
        * Initial packaging.
      cf0f0834
  4. 21 Aug, 2019 1 commit