1. 23 Nov, 2021 1 commit
  2. 29 Mar, 2021 2 commits
  3. 15 Mar, 2021 3 commits
  4. 01 Mar, 2021 3 commits
  5. 15 Jun, 2020 1 commit
    • Paride Legovini's avatar
      Import Debian changes 0.2.9-1 · 0d8f37fb
      Paride Legovini authored
      fscrypt (0.2.9-1) unstable; urgency=medium
      .
        * New upstream version 0.2.9.
        * Drop patch: 0001-cmd-fscrypt-fix-32-bit-build (upstreamed).
      .
      fscrypt (0.2.8-1) unstable; urgency=medium
      .
        * New upstream version 0.2.8.
          - closes: #957239 (https://github.com/google/fscrypt/pull/224)
          - closes: #959531 (https://github.com/google/fscrypt/pull/221)
        * New patch: 0001-cmd-fscrypt-fix-32-bit-build.patch (cherry-pick)
      .
      fscrypt (0.2.7-1) unstable; urgency=medium
      .
        * New upstream version 0.2.7 (closes: #959163).
        * d/rules: run dh_auto_install with --no-source.
        * d/rules: do not try to force -buildmode=pie.
        * d/control: bump the dh compat level to 13.
        * d/control: use the paride@debian.org alias in Uploaders.
      .
      fscrypt (0.2.6-1) unstable; urgency=medium
      .
        * New upstream version 0.2.6 (closes: #952667).
        * d/copyright: drop the Files-Excluded section (not needed).
        * d/control: bump Standards-Version to 4.5.0 (no changes needed).
        * d/rules: the 'crypto' testsuite has been renamed to 'keyring'.
      .
      fscrypt (0.2.5-2) unstable; urgency=medium
      .
        * The upstream libpam config file is now a template; compile it.
          (Closes: #946155)
        * Build-Depend on m4.
      .
      fscrypt (0.2.5-1) unstable; urgency=medium
      .
        * New upstream version 0.2.5 (Closes: #945398).
        * Build-Depend on debhelper-compat and drop d/compat.
        * Bump Standards-Version to 4.4.1 (no changes needed).
        * d/control: add Rules-Requires-Root: no.
        * d/rules: drop DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed.
          ld --as-needed is enabled by default on Debian development versions.
      0d8f37fb
  6. 15 Mar, 2021 1 commit
  7. 01 Nov, 2019 2 commits
  8. 25 Aug, 2018 1 commit
    • Paride Legovini's avatar
      Import Debian changes 0.2.4-2 · 3daa56ec
      Paride Legovini authored
      fscrypt (0.2.4-2) unstable; urgency=medium
      
        * Use team+pkg-go@tracker.debian.org in Maintainer
        * Versioned dependency on golang-any >= 2:1.10~ (see README.md)
        * Disable filesystem tests (require an ad-hoc filesystem and root)
          Fixes FTBFS on ppc64el.
        * Versioned dependency on dh-golang >= 1.35 (fixes FTBFS with gccgo-8)
        * Make the PAM library installation rules work with gccgo-go
      
      fscrypt (0.2.4-1) unstable; urgency=medium
      
        * New upstream version. Fixes: CVE-2018-6558.
        * Bump Standards-Versions to 4.2.0 (no changes needed)
        * gbp.conf: set upstream-branch = upstream/latest (DEP14)
        * Improve the installation rules for the binary and PAM library
        * Run all the tests but the failing ones instead of disabling all of them
        * Verbose build (DH_VERBOSE = 1)
      
      fscrypt (0.2.3-2) unstable; urgency=medium
      
        * Do not set ‘-buildmode=pie’ on mips/mipsel/mips64el
        * Fix the PAM library installation rule for non-amd64 archs
      
      fscrypt (0.2.3-1) unstable; urgency=medium
      
        * Initial release (Closes: #894406)
      3daa56ec