Commit d4927d7d authored by Andreas Henriksson's avatar Andreas Henriksson

Add Build-Depends-Package to debian/*.symbols

This makes it possible for packages who want to generate stricter
dependencies than needed by the symbols they use to do so.  The version
in their build-dependency will be used if it's higher than any of the
versions listed for the used symbols when we specify this magic field.
Better have it before we actually need it, because by then it's to late
to add it.
parent e2770283
libblkid.so.1 libblkid1 #MINVER#
* Build-Depends-Package: libblkid-dev
BLKID_1.0@BLKID_1.0 2.16
BLKID_2.15@BLKID_2.15 2.16
BLKID_2.17@BLKID_2.17 2.17.2
......
libfdisk.so.1 libfdisk1 #MINVER#
* Build-Depends-Package: libfdisk-dev
FDISK_2.26@FDISK_2.26 2.26.2
FDISK_2.27@FDISK_2.27 2.26.2
FDISK_2.28@FDISK_2.28 2.28~rc1
......
libmount.so.1 libmount1 #MINVER#
* Build-Depends-Package: libmount-dev
MOUNT_2.19@MOUNT_2.19 2.19.1
MOUNT_2.20@MOUNT_2.20 2.20.1
MOUNT_2.21@MOUNT_2.21 2.24.2
......
libsmartcols.so.1 libsmartcols1 #MINVER#
* Build-Depends-Package: libsmartcols-dev
SMARTCOLS_2.25@SMARTCOLS_2.25 2.25
SMARTCOLS_2.27@SMARTCOLS_2.27 2.27~rc1
SMARTCOLS_2.28@SMARTCOLS_2.28 2.28~rc1
......
libuuid.so.1 libuuid1 #MINVER#
* Build-Depends-Package: uuid-dev
UUIDD_PRIVATE@UUIDD_PRIVATE 2.20.1
UUID_1.0@UUID_1.0 2.16
UUID_2.20@UUID_2.20 2.20.1
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment