• Jeremy Bicha's avatar
    Import Debian changes 2.1.6-5 · fb771d24
    Jeremy Bicha authored
    tracker (2.1.6-5) unstable; urgency=medium
    
      * Add -Wl,-O1 to our LDFLAGS
      * Bump Standards-Version to 4.3.0
    
    tracker (2.1.6-4) unstable; urgency=medium
    
      * Build with autotools again instead of meson because of autopkgtest
        regressions seen when built with meson. See bug 915551
    
    tracker (2.1.6-3) unstable; urgency=medium
    
      * Cherry-pick functional-tests-Require-Bash-for-test-runner.patch
      * Update autopkgtests for meson build
      * autopkgtest: Depend on dbus-x11, gir1.2-glib-2.0 & python-gi
      * autopkgtest: Don't use xvfb
    
    tracker (2.1.6-2) unstable; urgency=low
    
      * Build with meson
      * Cherry-pick build-Restore-right-soversion-to-libraries.patch
      * Use -c4 for dpkg-gensymbols
      * Build-Depend on bash-completion & libdbus-1-dev
      * Adjust rules for missing symlinks for some libraries with meson
    
    tracker (2.1.6-1) unstable; urgency=medium
    
      * New upstream release
      * Cherry-pick libtracker-miners-common-Make-g_error-a-soft-error.patch:
        - Allow tracker library to still be used without ontology rules
          (Closes: #908800)
    
    tracker (2.1.4-1) unstable; urgency=medium
    
      * New upstream release (LP: #1791484)
      * debian/rules: Use dh_auto_test instead of make check
      * Drop git-fix-build-with-format-security.patch: Applied in new release
      * Bump Standards-Version to 4.2.1
      * Release to unstable
    
    tracker (2.1.3-1) experimental; urgency=medium
    
      * New upstream release
      * debian/control.in: Bump build-dep on sqllite to 3.8.3
      * debian/libtracker-sparql-2.0-0.symbols: Add new symbols
      * d/p/git-fix-build-with-format-security.patch: fix FTBFS
    
    tracker (2.0.3-3) unstable; urgency=medium
    
      * debian/tests/unit-tests: whitelist messages dbus prints on stderr
        when it is activating services.
    
    tracker (2.0.3-2) unstable; urgency=medium
    
      [ Gianfranco Costamagna ]
      * Add patches from Ubuntu to skip broken tests so that the autopkgtests pass
        again. New failing tests were introduced in 2.0.2. See GNOME bug 793723.
    
      [ Jeremy Bicha ]
      * Bump Standards-Version to 4.1.4
    
    tracker (2.0.3-1) unstable; urgency=medium
    
      * New upstream release
      * Update Vcs fields for migration to https://salsa.debian.org/
      * Bump debhelper compat to 11
    
    tracker (2.0.2-1) unstable; urgency=medium
    
      [ Jeremy Bicha ]
      * Bump Standards-Version to 4.1.1
    
      [ Simon McVittie ]
      * Add Provides to gir1.2-tracker-2.0 to reflect its contents
    
      [ Michael Biebl ]
      * New upstream version 2.0.2
      * Update list of Uploaders via gnome-pkg-tools
    
    tracker (2.0.1-1) unstable; urgency=medium
    
      * New upstream version 2.0.1
    
    tracker (2.0.0-3) unstable; urgency=medium
    
      * Move package from collab-maint to pkg-gnome
    
    tracker (2.0.0-2) unstable; urgency=medium
    
      * Release to unstable
    
    tracker (2.0.0-1) experimental; urgency=medium
    
      * New upstream version 2.0.0
    
    tracker (1.99.3-1) experimental; urgency=medium
    
      * New upstream version 1.99.3
      * Set Debian GNOME team as Maintainer
    
    tracker (1.99.2-1) experimental; urgency=medium
    
      [ Jeremy Bicha ]
      * New upstream version 1.99.2
      * Drop all patches, obsolete
      * Drop stuff split to tracker-miners source
    
      [ Michael Biebl ]
      * Drop more obsolete Build-Depends
      * Switch to new dh_missing helper
      * Switch to --fail-missing
    
    tracker (1.99.1-1) experimental; urgency=medium
    
      * New upstream version 1.99.1
      * Track unstable releases
      * Drop tracker-miner-evolution
      * Drop tracker-gui
      * Drop obsolete configure switches
      * Rename packages for the API bump from 1.0 → 2.0
      * Drop tracker-miner-user-guides related files
      * Update symbols files
      * Add a Build-Depends-Package field to all symbols files
      * Fix format-security issue in libtracker-data
      * Remove leftover @LIBTRACKER_MINER_PC_REQUIRES@ from tracker-miner.pc.in
      * Install default domain ontology
    
    tracker (1.12.1-1) unstable; urgency=medium
    
      * New upstream version 1.12.1
      * Bump Standards-Version to 4.0.0
    
    tracker (1.12.0-1) unstable; urgency=medium
    
      * New upstream version 1.12.0
      * Drop no longer needed Build-Depends on libgee-0.8-dev
      * Add Build-Depends on libjson-glib-dev and libsoup2.4-dev
      * Update symbols file for libtracker-sparql-1.0-0
      * Add gir related lintian overrides
      * Revert "Drop lintian overrides, tracker now sets RUNPATH rather than RPATH"
    
    tracker (1.10.5-1) unstable; urgency=medium
    
      * New upstream release
        - tracker-extract: Further sandboxing fixes. (Closes: #853723)
      * Use the same URL for Vcs-Git and Vcs-Browser, both via https
      * Update URLs in debian/copyright to use https
      * Rebase patches
    
    tracker (1.10.4-1) unstable; urgency=medium
    
      [ Michael Biebl ]
      * New upstream release.
        - tracker-extract: Whitelist multiple innocuous syscalls that were
          reported to raise false positives in the extraction sandbox.
          (Closes: #848842, #849936, LP: #1649035, LP: #1649004)
    
      [ Simon McVittie ]
      * Disable libmediaart. It makes tracker-extract write to the filesystem (in
        its cache directory), which is incompatible with the seccomp sandbox
        introduced in 1.10.2.
      * Don't immediately restart tracker-extract on SIGSYS. Mitigates: #851148
    
    tracker (1.10.3-1) unstable; urgency=medium
    
      * Update debian/watch to version 4 and use new "special strings" to
        standardize format. Track stable releases only.
      * New upstream release.
      * Add Depends on libglib2.0-bin. The tracker-store autostart file uses gdbus
        to start the service via D-Bus.
    
    tracker (1.10.2-1) unstable; urgency=medium
    
      * New upstream release.
      * Add Build-Depends on libseccomp-dev on Linux.
        This is a new dependency which was added to let the extractor threads run
        in a sandbox. Filesystem and network access are limited to being read and
        local only.
    
    tracker (1.10.1-1) unstable; urgency=medium
    
      * New upstream release.
      * Use sysctl to increase the inotify watches instead of running the SysV
        init script from procps.
    
    tracker (1.10.0-1) unstable; urgency=medium
    
      * New upstream release.
      * Add Build-Depends on dpkg-dev (>= 1.17.14) to ensure we have a version
        which supports the <!nocheck> restriction.
    
    tracker (1.9.2-1) unstable; urgency=medium
    
      * New upstream release.
      * Install nautilus extension into multiarch path.
      * Bump debhelper compat level to 10.
      * Use dbus-run-session to run the test-suite.
      * Depend on default-dbus-session-bus | dbus-session-bus instead of dbus.
    
    tracker (1.9.1-2) unstable; urgency=medium
    
      * Install systemd user service files.
    
    tracker (1.9.1-1) unstable; urgency=medium
    
      * New upstream release.
      * Drop docs-Do-not-delete-xml-directory-when-redoing-docs.patch, merged
        upstream.
      * Update Build-Depends:
        - Bump libglib2.0-dev to (>= 2.44.0).
        - Bump libpng-dev to (>= 1.2).
        - Bump libsqlite3-dev to (>= 3.7.15).
        - Drop libpango1.0-dev and xsltproc.
      * Update symbols files with new additions, like the new tracker-ressource
        API.
    
    tracker (1.8.0-4) unstable; urgency=medium
    
      * Do not delete xml directory when redoing docs as this might lead to build
        failures due to race conditions.
    
    tracker (1.8.0-3) unstable; urgency=medium
    
      * Team upload.
      [ Pino Toscano ]
      * Enable parallel building (Closes: #823268)
    
      [ Laurent Bigonville ]
      * Drop dependency against gnome-icon-theme, this package is deprecated
      * Bump Standards-Version to 3.8.9 (no further changes)
    
    tracker (1.8.0-2) unstable; urgency=medium
    
      * Upload to unstable.
    
    tracker (1.8.0-1) experimental; urgency=medium
    
      * New upstream release.
    
    tracker (1.7.5-1) experimental; urgency=medium
    
      * New upstream release.
      * Remove old, unused dbus interface xml for tracker-extract.
    
    tracker (1.7.4-1) experimental; urgency=medium
    
      * New upstream release.
      * Drop dbg package now that we have automatic dbgsym packages.
      * Drop compat binaries, they are no longer provided by upstream.
      * Ensure proper upgrade from tracker-dbg to new dbgsym packages by using
        dh_strip --dbgsym-migration. Bump Build-Depends on debhelper accordingly.
      * Use the architecture.mk Makefile snippet provided by dpkg-dev to retrieve
        DEB_HOST_MULTIARCH.
      * Bump Standards-Version to 3.9.7.
    fb771d24
Name
Last commit
Last update
..
build-Restore-right-soversion-to-libraries.patch Loading commit data...
disable-miner-fs-test.patch Loading commit data...
drop-assert.patch Loading commit data...
functional-tests-Require-Bash-for-test-runner.patch Loading commit data...
libtracker-miners-common-Make-g_error-a-soft-error.patch Loading commit data...
series Loading commit data...
test.patch Loading commit data...