Commit a66c8d1f authored by Emanuele Aina's avatar Emanuele Aina

chaiwala-apparmor-profiles: Fix conflict with pulseaudio in Buster

The version of the pulseaudio package in Buster has no epoch, so
`Breaks: pulseaudio (<< 1:8.0-0ubuntu3co4~)` causes APT to uninstall pulseaudio
or chaiwala-apparmor-profiles when the other is installed.

With the curren recipes this causes chaiwala-apparmor-profiles to be removed as
pulseaudio is installed later.

Drop the reference to old Ubuntu versions both for pulseaudio and apparmor now
that we moved on top of Debian Buster.
Signed-off-by: Emanuele Aina's avatarEmanuele Aina <emanuele.aina@collabora.com>
parent 3bb4be31
......@@ -37,13 +37,8 @@ Package: chaiwala-apparmor-profiles
Architecture: all
Pre-Depends: ${misc:Pre-Depends}
Depends:
apparmor (>= 2.11.0-2ubuntu5~),
apparmor,
${misc:Depends},
Breaks:
apparmor (<< 2.9.1-0ubuntu9co2~),
pulseaudio (<< 1:8.0-0ubuntu3co4~),
Replaces:
apparmor (<< 2.9.1-0ubuntu9co2~),
Description: Apertis-specific AppArmor profiles
This package installs a set of AppArmor profiles and abstractions which are
specific to Apertis.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment