Commit a6ac88cd authored by Emanuele Aina's avatar Emanuele Aina

license-exceptions: Fix the GCC version to what is currently shipped

After the rebase to Debian Buster Apertis is shipping gcc-8.
Signed-off-by: Emanuele Aina's avatarEmanuele Aina <emanuele.aina@collabora.com>
parent c66d5012
......@@ -22,20 +22,20 @@ Each exception must provide the following informations:
| rule | The rules that are ignored by this exception |
| reason | A description of why the exception is granted and makes sense |
## gcc-5
## gcc-8
| name | description |
| ---- | ----------- |
| project | gcc-5 |
| project | gcc-8 |
| location | OBS |
| component | apertis:*:target |
| date | April 17, 2019 |
| validator | fredo |
| rule | No GPL v3 |
| reason | Gcc-5 is granted exception to be present in target repository component |
| reason | GCC is granted exception to be present in target repository component |
| | even though it is licensed under the GPL v3 because it is |
| | a build time dependency of other projects in target. |
| | Gcc itself is not delivered on the generated target images. |
| | GCC itself is not delivered on the generated target images. |
| | It is not intended that the user of Apertis devices uses gcc on the target. |
| | This usage is explicitely allowed by gcc authors thanks to the |
| | [GCC Runtime Library Exceptions](https://www.gnu.org/licenses/gcc-exception-3.1-faq.html) |
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment